[SQL] Błąd konwersji - Nie można przydzielić nowej strony do bazy danych

Rafał Kowalski
Rafał Kowalski
  • Zaktualizowano

Problem:

Podczas próby konwersji bazy danych pojawia się błąd:
Nie można przydzielić nowej strony do bazy danych […], z powodu niewystarczającej ilości miejsca na dysku w grupie plików PRIMARY

mceclip0.png

 

Przyczyna:

Rozmiar bazy jest bliski 10GB konwersja bazy sprawia, że baza rośnie i przekracza dostępny limit w SQL Express. Rozmiar bazy można zweryfikować za pomocą SSMS lub plików bazodanowych.

Rozwiązanie:

W pojedynczych przypadkach, chwilowym obejściem będzie wykonanie SHRINK'a na bazie danych. Pełnym rozwiązaniem jest przejście na pełną wersję SQL.
 
Opis dot. SHRINK dostępny jest na wsparciu Microsoftu
https://support.microsoft.com/pl-pl/topic/zmniejszanie-bazy-danych-tempdb-w-programie-sql-server-ea0a95c2-eff8-7075-9ee2-2ee42226ca1c

Czy ten artykuł był pomocny?

Liczba użytkowników, którzy uważają ten artykuł za przydatny: 0 z 0